[백준] 1463 1로 만들기
Algorithm 2019. 8. 13. 16:17https://www.acmicpc.net/problem/1463
1로 만들기 성공
2 초 | 128 MB | 80115 | 26214 | 16738 | 32.155% |
시간 제한메모리 제한제출정답맞은 사람정답 비율
문제
정수 X에 사용할 수 있는 연산은 다음과 같이 세 가지 이다.
- X가 3으로 나누어 떨어지면, 3으로 나눈다.
- X가 2로 나누어 떨어지면, 2로 나눈다.
- 1을 뺀다.
정수 N이 주어졌을 때, 위와 같은 연산 세 개를 적절히 사용해서 1을 만들려고 한다. 연산을 사용하는 횟수의 최솟값을 출력하시오.
입력
첫째 줄에 1보다 크거나 같고, 106보다 작거나 같은 정수 N이 주어진다.
출력
첫째 줄에 연산을 하는 횟수의 최솟값을 출력한다.
예제 입력 1 복사
2
예제 출력 1 복사
1
예제 입력 2 복사
10
예제 출력 2 복사
3
힌트
10의 경우에 10 -> 9 -> 3 -> 1 로 3번 만에 만들 수 있다.
top-down 방식
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
|
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
namespace algorithm_11047
{
class Program
{
static void Main(string[] args)
{
new Solution();
}
}
class Solution {
int count = 0;
int[] arr = new int[1000001];
public Solution() {
var input = Console.ReadLine();
int n = int.Parse(input);
this.count = Func(n);
Console.WriteLine(count);
}
public int Func(int n) {
if (n == 1) {
return 0;
}
if (arr[n] > 0) {
return arr[n];
}
arr[n] = Func(n - 1) + 1;
if (n % 3 == 0)
{
var temp = Func(n / 3) + 1;
if (arr[n] > temp)
{
arr[n] = temp;
}
}
if (n % 2 == 0)
{
var temp = Func(n / 2) + 1;
if (arr[n] > temp)
{
arr[n] = temp;
}
}
return arr[n];
}
}
}
|
button-up방식
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
|
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
namespace algorithm_11047
{
class Program
{
static void Main(string[] args)
{
new Solution();
}
}
class Solution {
int[] arr;
public Solution() {
var input = Console.ReadLine();
int n = int.Parse(input);
this.ButtonUp(n);
}
public void ButtonUp(int n) {
this.arr = new int[n + 1];
this.arr[0] = this.arr[1] = 0;
for (int i = 2; i <= n; i++) {
this.arr[i] = this.arr[i - 1] + 1;
}
Console.WriteLine(this.arr[n]);
}
}
}
|
'Algorithm' 카테고리의 다른 글
재귀와 역추적 (0) | 2019.08.14 |
---|---|
피보나치 수열 (0) | 2019.08.14 |
[백준] 11047 동전 0 (진행중) (0) | 2019.08.13 |
[백준] ATM 11399 (0) | 2019.08.12 |
설탕 배달 (0) | 2019.06.11 |